The scheduled maintenance has been partially completed. Servers that did not move will be re scheduled later on.
Posted Oct 04, 2022 - 03:16 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 02, 2022 - 22:00 UTC
Scheduled
Start time : 02/10/2022 22:00 UTC End time : 04/10/2022 04:00 UTC Service impact : Servers will be unreachable for 30 minutes during the operation. Related Incident :[RBX3][Dedicated Servers] - 45B27 Service improvement : We are moving over the servers from rack 45B27. This resolved the issue with the remote reboot device being unavailable.
Posted Sep 20, 2022 - 16:00 UTC
This scheduled maintenance affected: Dedicated Servers || Global Infrastructure (RBX).