Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 22, 2022 - 23:01 UTC
Scheduled
Start time : 22/11/2022 23:00 UTC End time : 23/11/2022 05:00 UTC Service impact : Servers will be unreachable during the maintenance (30 minutes per server) Service improvement : The objective of this maintenance is to move servers the rack 16D06.
Posted Nov 15, 2022 - 21:52 UTC
This scheduled maintenance affected: Dedicated Servers || Network (RBX).