Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 27, 2025 - 04:00 UTC
Scheduled
As part of our continuous improvement plan, maintenance is scheduled on our Dedicated Servers infrastructure.
Start time : 27/10/2025 04:00 UTC End time : 31/10/2025 16:00 UTC Service impact : From 29/10/2025 05:00 UTC to 29/10/2025 17:00 UTC, you may experience public network interruption on racks L101A11, L101A12, L101B11, L101B12 and L112B03 during this maintenance. Service improvement : As part of our continuous improvement policy of our Dedicated Servers infrastructure, we will have to carry out interventions on the specified racks.
Thank you for your understanding.
Posted Oct 14, 2025 - 14:52 UTC
This scheduled maintenance affected: Dedicated Servers || Network (LIM).