The scheduled maintenance has been completed. All the services are now operational since 20/03/2025 03:06 UTC
Posted Mar 20, 2025 - 03:21 UTC
Update
This maintenance is taking longer than expected. An update will be made when the work is completed.
We apologise for any inconvenience
Posted Mar 20, 2025 - 02:02 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 19, 2025 - 23:00 UTC
Scheduled
As part of our continuous improvement plan, maintenance is scheduled on our Dedicated Servers offer.
This may temporarily affect availability.
Start time : 19/03/2025 23:00 UTC End time : 20/03/2025 01:00 UTC Service impact : Each server in rack 46C07 will be temporarily unavailable for 15 minutes during the operation. Service improvement : As part of our continuous improvement policy, we will be migrating servers from rack 46C07 to rack 46C08.
Thank you for your understanding.
Posted Mar 04, 2025 - 19:09 UTC
This scheduled maintenance affected: Dedicated Servers || Network (RBX).