Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 22, 2026 - 00:30 UTC
Scheduled
As part of our continuous improvement plan, maintenance is scheduled on our Dedicated Servers offer, affecting servers in racks G132B25,G132B24, G132B23 ,G132B22, G132B16 ,G132B15,G132B14 , G132B13, G132B12 , G132B11,G132B10,G132A23,G132B09 ,G132B06,G132A21,G132B04,G132B02 and G132B03 .
Start time : 22/01/2026 00:30 UTC End time : 22/01/2026 03:30 UTC Service impact : Public networks will be temporarily unavailable during the maintenance. Service improvement : Following our continuous improvement policy of our network infrastructure, we will be doing a maintenance on multiple network equipment.
Thank you for your understanding.
Posted Jan 08, 2026 - 05:14 UTC
This scheduled maintenance affected: Dedicated Servers || Network (GRA).