We would like to inform you that the maintenance on our is now completed. All services are operational.
Thank you for your patience throughout this maintenance.
Posted Nov 12, 2025 - 12:15 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 12, 2025 - 10:01 UTC
Scheduled
As part of our continuous improvement plan, a change is scheduled on the installation process for Debian 13 and Proxmox VE 9 installation on UEFI Dedicated servers.