We are pleased to inform you that the incident affecting our Virtual Private Servers offering has been resolved.
Start time : 21/05/2026 22:45 UTC End time : 21/05/2026 23:14 UTC Root Cause : A service disruption occurred due to an unexpected underlying infrastructure malfunction.
We apologize for any inconvenience caused and appreciate your understanding.
Posted May 21, 2026 - 23:22 UTC
Identified
We are currently experiencing an incident affecting our Virtual Private Servers offering in the BHS5 Region. The root cause has been identified.
Please find the details of this incident below : Start time : 21/05/2026 22:45 UTC Impacted Service(s) : Some instances in the BHS5 region are unreachable. Customers Impact : Customers are temporarily unable to access and use their instances located on the specified region. Root Cause : A service disruption occurred due to an unexpected underlying infrastructure malfunction. Ongoing Actions : Our teams are actively working to restore service as quickly as possible.
We will keep you updated on the progress and resolution. We apologize for any inconvenience caused and appreciate your understanding.
Posted May 21, 2026 - 23:09 UTC
This incident affected: Virtual Private Servers || Network (BHS).