Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 05, 2024 - 19:00 UTC
Scheduled
As part of our continuous improvement plan, maintenance is scheduled on our Baremetal offer.
Start time : 05/11/2024 19:00 UTC End time : 06/11/2024 07:00 UTC Service impact : None Service improvement : As part of our continuous improvement policy, our teams will be doing a maintenance on multiple network equipment.
Thank you for your understanding.
Posted Oct 31, 2024 - 23:22 UTC
This scheduled maintenance affected: Dedicated Servers || Network (RBX).