Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 08, 2024 - 07:00 UTC
Scheduled
As part of our continuous improvement plan, maintenance is scheduled on our network infrastructure.
Start time : 08/10/2024 07:00 UTC End time : 08/10/2024 10:00 UTC Service impact : None. Service improvement : As part of our continuous improvement policy of our network infrastructure, we will have to carry out interventions on a network equipment.
Posted Oct 03, 2024 - 17:57 UTC
This scheduled maintenance affected: Dedicated Servers || Network (BHS).