Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 03, 2022 - 08:01 UTC
Scheduled
Start time : 03/05/2022 08:00 UTC End time : 03/05/2022 10:00 UTC Service impact : None Service improvement : A maintenance will be carried out to improve our NasHA services.
Posted Apr 26, 2022 - 23:00 UTC
This scheduled maintenance affected: Storage and Backups || NAS HA (RBX, SBG).