We apologize for any inconvenience caused and appreciate your understanding.
Posted May 19, 2026 - 14:33 UTC
Identified
We are currently experiencing an incident affecting our Enterprise File Storage offering in the LIM and RBX Regions. The root cause has been identified.
Please find the details of this incident below : Start time : 19/05/2026 08:00 UTC Service impact: Enterprise File Storage Service is temporarily unavailable in the specified regions. Customers Impact : Customers are temporarily unable to access their data. Root Cause : This incident is caused by this maintenance : https://network.status-ovhcloud.com/incidents/477q4g38610z Ongoing Actions : Our teams are actively working to restore service as quickly as possible.
We will keep you updated on the progress and resolution. We apologize for any inconvenience caused and appreciate your understanding.
Posted May 19, 2026 - 14:20 UTC
This incident affected: Storage and Backups || Enterprise File Storage (LIM, RBX).