Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 29, 2026 - 11:00 UTC
Scheduled
As part of our continuous improvement plan, a maintenance is scheduled on our network infrastructure in GRA6 region.
Start time : 29/05/2026 11:00 UTC End time : 29/05/2026 12:00 UTC Service impact : Some instances in GRA6 region will be temporarily unavailable during the operation. Service improvement : As part of our continuous improvement policy, we will be doing a maintenance on our Network infrastructure in the specified regions.
Thank you for your understanding.
Posted May 29, 2026 - 10:55 UTC
This scheduled maintenance affected: Virtual Private Servers || Network (GRA).