We are pleased to inform you that the incident affecting our Dedicated Servers has been resolved.
Start time : 26/02/2026 05:30 UTC End time : 27/02/2026 10:40 UTC Root Cause : This incident was caused by a cooling system issue.
We apologize for any inconvenience caused and appreciate your understanding.
Posted Feb 27, 2026 - 11:15 UTC
Update
We have new information regarding the incident that affected your service(s).
Please find below an update on the situation: Update : Most of the affected servers are now available again. Ongoing Actions : Our teams are continuing to fix the last few servers that were affected.
We will keep you updated on the progress and resolution.
We apologize for any inconvenience caused and appreciate your understanding.
Posted Feb 27, 2026 - 09:25 UTC
Update
We have new information regarding the incident that affected your service(s).
Please find below an update on the situation: Update : Our technical team is actively working on the incident affecting rack 46L02. A significant number of servers have now been successfully restored and are back online. Ongoing Actions : The incident has been identified and our teams are mobilised to restore service as quickly as possible.
We will keep you updated on the progress and resolution.
We apologize for any inconvenience caused and appreciate your understanding.
Posted Feb 27, 2026 - 04:15 UTC
Update
We have new information regarding the incident that affected your service(s).
Please find below an update on the situation: Update : Our technical team is actively working on the incident affecting rack 46L02. A significant number of servers have now been successfully restored and are back online. Ongoing Actions : The incident has been identified and our teams are mobilised to restore service as quickly as possible.
We will keep you updated on the progress and resolution.
We apologize for any inconvenience caused and appreciate your understanding.
Posted Feb 26, 2026 - 20:34 UTC
Update
We have new information regarding the incident that affected your service(s).
Please find below an update on the situation: Update : All hosts are now fully operational on Racks 46L03 and 46L04. Customers can once again use their services without any restrictions. Ongoing Actions : Operations on Rack 46L02 are still in progress.
We will keep you updated on the progress and resolution.
We apologize for any inconvenience caused and appreciate your understanding.
Posted Feb 26, 2026 - 09:54 UTC
Update
The majority of impacted hosts have now been successfully restored on racks 46L03 and 46L04. Services running on these platforms have returned to normal operations.
Our teams are still actively working on the remaining rack 46L02 to complete the ongoing operations and ensure full stability.
📌 Current status:
✅ 46L03 / 46L04: Majority of hosts restored and operating normally
🔧 46L02: Operations still in progress
At this stage, no additional customer impact is expected. We continue to closely monitor the situation until full resolution.
Posted Feb 26, 2026 - 07:04 UTC
Identified
We are currently investigating an incident affecting our Dedicated Servers offering, which is causing temporary availability issue in racks 46L02/46L03/46L04.
Here are some supplementary details :
Start time : 26/02/2026 05:30 UTC Impacted Service(s) : All servers in racks 46L02/46L03/46L04 are temporarily unavailable. Customers Impact : Customers are not available to reach their servers Ongoing Actions : Our teams are investigating to determine the origin of the incident and fix it. Rootcause : This incident is caused by a cooling system issue.
We will keep you updated on the progress and resolution.
We apologize for any inconvenience caused and appreciate your understanding.
Posted Feb 26, 2026 - 06:00 UTC
This incident affected: Dedicated Servers || Global Infrastructure (RBX).