Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 03, 2026 - 00:30 UTC
Update
Please note the new start time of this maintenance : Start time : 03/03/2026 00:30 UTC End time : 03/03/2026 03:30 UTC
Posted Mar 02, 2026 - 14:36 UTC
Scheduled
As part of our continuous improvement plan, maintenance is scheduled on our network infrastructure.
Start time : 03/03/2026 00:30 UTC End time : 03/03/2026 03:30 UTC Service impact : The private network (vRack) will be temporarily unavailable for approximately 45 minutes for the servers located in the racks listed below :
Please note that the maintenance may take less time than expected. Service improvement : Following our continuous improvement policy, we will be doing a maintenance on multiple network equipment.
Thank you for your understanding.
Posted Feb 24, 2026 - 21:50 UTC
This scheduled maintenance affected: Dedicated Servers || Network (GRA).