We have new information regarding the maintenance :
Please find below an update on the maintenance : Update : Some servers located in rooms B702, B703, B707 and B709 are temporarily unavailable. The power has been restored on the specified racks. Our teams are now restarting the remaining servers.
We’ll keep you updated on the progress of this maintenance.
Thank you for your understanding.
Posted Mar 10, 2026 - 19:24 UTC
Update
We have new information regarding the maintenance :
Please find below an update on the maintenance : Update : The power has been restored on the rack. Our teams are now restarting the remaining servers.
We’ll keep you updated on the progress of this maintenance.
Thank you for your understanding.
Posted Mar 10, 2026 - 12:08 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 10, 2026 - 10:00 UTC
Scheduled
As part of our continuous improvement plan, we will be carrying out a maintenance on our electrical infrastructure.
Start time : 10/03/2026 10:00 UTC End time : 10/03/2026 20:00 UTC Service impact : Some servers located in rooms B702, B703, B707 and B709 might be temporarily unavailable from 10:30 UTC during the maintenance . Service improvement : As part of our continuous improvement policy, we will be doing a maintenance on our electrical infrastructure.
Thank you for your understanding.
Posted Jan 13, 2026 - 21:42 UTC
This scheduled maintenance affected: Dedicated Servers || Global Infrastructure (BHS).