Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 15, 2023 - 10:00 UTC
Scheduled
Start time : 15/05/2023 10:00 UTC End time : 15/05/2023 10:30 UTC Service impact : vRack will be unavailable for servers in rack B713B01 during the maintenance Service improvement : Following our continuous improvement policy of our network infrastructure, we will be doing an internal maintenance on a network equipment.
Posted Apr 27, 2023 - 23:18 UTC
This scheduled maintenance affected: Dedicated Servers || Network (BHS).