Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 21, 2022 - 10:00 UTC
Scheduled
Start time : 21/04/2022 10:00 UTC End time : 21/04/2022 12:00 UTC Service impact : 2 hours downtime during replacement. Service improvement : We will perform a replacement of the public and vRack devices due to down ports.
Posted Apr 14, 2022 - 22:01 UTC
This scheduled maintenance affected: Dedicated Servers || Network (BHS).