The scheduled maintenance has been completed. End time : 27/02/2025 03:20 UTC
Posted Feb 27, 2025 - 03:22 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 27, 2025 - 03:00 UTC
Scheduled
As part of our continuous improvement plan, maintenance is scheduled on our Dedicated Servers offer for the specific rack.
This may temporarily affect Availability.
Start time : 27/02/2025 03:00 UTC End time : 27/02/2025 04:00 UTC Service impact : Public network will be unavailable for 1 hour during the maintenance time. Service improvement : As part of our continuous improvement policy, we will be doing a maintenance on a network equipment.
Thank you for your understanding.
Posted Feb 18, 2025 - 15:03 UTC
This scheduled maintenance affected: Dedicated Servers || Network (RBX).