Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 13, 2023 - 17:30 UTC
Scheduled
Start time : 13/11/2022 17:30 UTC End time : 13/11/2022 22:30 UTC Service impact : None Service improvement : As part of our continuous improvement policy of our network infrastructure, we will be doing an internal maintenance on multiple network equipment.
Posted Nov 10, 2023 - 23:16 UTC
This scheduled maintenance affected: Dedicated Servers || Network (SGP).