Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 23, 2023 - 00:00 UTC
Update
The start time and end time have been changed Start time : 23/05/2023 23:59 UTC End time : 24/05/2023 03:00 UTC
Posted May 11, 2023 - 13:58 UTC
Scheduled
Start time : 23/05/2023 23:59 UTC End time : 24/05/2023 03:00 UTC Service impact : None Service improvement : As part of our continuous improvement policy of our network infrastructure, we will be doing a maintenance operation on network equipment.
Posted May 09, 2023 - 22:21 UTC
This scheduled maintenance affected: Dedicated Servers || Network (RBX).