Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 26, 2025 - 07:37 UTC
Scheduled
As part of our continuous improvement plan, we will be carrying out maintenance on our cooling infrastructure.
Start time : 26/03/2025 07:23 UTC End time : 26/03/2025 15:30 UTC Service impact : None Service improvement : Following our continuous improvement policy, we are doing some cooling system replacement.
Thank you for your understanding.
Posted Mar 26, 2025 - 07:36 UTC
This scheduled maintenance affected: Dedicated Servers || Global Infrastructure (GRA).