All services are operational. No more impact since 10:09 UTC.
Posted Oct 23, 2025 - 11:13 UTC
Update
We have new information regarding this maintenance that affected your service(s).
Please find below an update on the situation:
Update : The power has been restored on the rack. If you have trouble accessing your servers, please contact the support team. We will keep you updated on the progress of this maintenance.
We apologize for any inconvenience caused and appreciate your understanding.
Posted Oct 23, 2025 - 08:35 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 23, 2025 - 07:00 UTC
Scheduled
As part of our continuous improvement plan, maintenance is scheduled on our Dedicated Servers offer on rack E102G12.
This may temporarily affect availability. Start time: 23/10/2025 07:00 UTC End time: 23/10/2025 08:30 UTC Service impact: During the operation, servers in rack E102G12 will be temporarily unavailable. Service improvement: As part of our continuous improvement policy, we will migrate servers in rack E102G12 to rack ERI0102C01C.
Thank you for your understanding.
Posted Sep 17, 2025 - 21:51 UTC
This scheduled maintenance affected: Dedicated Servers || Global Infrastructure (ERI).