We would like to inform you that the maintenance on our Backup Storage is now completed. All services are operational.
Thank you for your patience throughout this maintenance.
Posted Mar 03, 2026 - 21:26 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 03, 2026 - 16:00 UTC
Scheduled
As part of our continuous improvement plan, maintenance is scheduled on our Backup Storage offer.
Start time : 03/03/2026 16:00 UTC End time : 04/03/2026 02:00 UTC Service impact : None Service improvement : As part of our continuous improvement policy, we will perform an update on our Backup Storage offer.
Thank you for your understanding.
Posted Mar 02, 2026 - 22:37 UTC
This scheduled maintenance affected: Storage and Backups || Backup Storage (RBX).