We are pleased to inform you that the incident affecting our Dedicated Servers offer on rack W16B12 has been resolved.
Start time : 11/03/2026 15:55 UTC End time : 11/03/2026 16:02 UTC Root Cause : This incident was caused by an electrical equipment issue.
We apologize for any inconvenience caused and appreciate your understanding.
Posted Mar 11, 2026 - 16:33 UTC
Monitoring
Service has been fully restored since 11/03/2026 16:02 UTC UTC. Monitoring remains active to ensure long-term stability.
Here are some supplementary details :
Start time : 11/03/2026 15:55 UTC Impacted Service(s) : All servers in the rack W16B12 were temporarily unavailable. Customers Impact : Customers were temporarily unable to access and use their servers in rack W16B12.
We apologize for any inconvenience caused and appreciate your understanding.
Posted Mar 11, 2026 - 16:25 UTC
This incident affected: Dedicated Servers || Global Infrastructure (WAW).