Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 31, 2023 - 19:01 UTC
Scheduled
Start time : 31/05/2023 19:00 UTC End time : 01/06/2023 02:00 UTC Service impact : Management IP might be unavailable for 3 minutes on some servers in RBX1 Service improvement : As part of our continuous improvement policy of our network infrastructure, we will be doing a maintenance on multiple network equipment
Posted May 27, 2023 - 00:03 UTC
This scheduled maintenance affected: Dedicated Servers || Network (RBX).