Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 06, 2023 - 03:30 UTC
Scheduled
Start time : 06/11/2023 03:30 UTC End time : 06/11/2023 04:30 UTC Service impact : Public network will be unavailable during the maintenance for servers in rack R715A05 Service improvement : As part of our continuous improvement policy of our network infrastructure, we will be doing a maintenance on a network equipment.
Posted Oct 24, 2023 - 20:38 UTC
This scheduled maintenance affected: Dedicated Servers || Network (RBX).