Start time : 17/09/2023 20:29 UTC End time : 17/09/2023 20:52 UTC Root cause : Infrastructure issue. Our technical teams resolved the issue. All impacted services are now operational.
Posted Sep 17, 2023 - 21:21 UTC
Investigating
Start time : 17/09/2023 20:29 UTC Service impact : Public network is down. Ongoing actions : Investigating Our technical teams are working on the issue. Update will be posted as significant progress is made.
Posted Sep 17, 2023 - 20:37 UTC
This incident affected: Dedicated Servers || Network (RBX).