Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 28, 2025 - 18:00 UTC
Scheduled
As part of our continuous improvement plan, a maintenance is scheduled on our Dedicated Servers offering in RBX1.
Start time : 28/07/2025 18:00 UTC End time : 01/08/2025 02:00 UTC Service impact : Some servers will be temporarily unavailable for a while during maintenance. Service improvement : As part of our continuous improvement policy, our teams will be doing a moving some servers from RBX1 to RBX3. The customers received a communication from our technical support to inform them of the migration.
Thank you for your understanding.
Posted Jul 08, 2025 - 22:17 UTC
This scheduled maintenance affected: Dedicated Servers || Global Infrastructure (RBX).